An Electric Scooter Community on a Mission to Stamp out Transportation Mediocrity.

Enjoy the juice
Do you need to have the motor controller connected to external power when trying to flash? Because I completely disconnected the motor controller from all cables and took it to another room for flashing and for now I am getting "Can not communicate..."
It worked now. The trick was to press 'connect' and then immediately to connect pin 7 to ground.

However, no overall success. The display part of the scooter I got is totally broken (also no green/yellow/red bar). After reconnecting the controller, the lights turn on. But no response on the throttle. I suspect it has to do with the display part? I don't know.
Ivitohappy wrote:
Ivitohappy wrote:
Thu Oct 21, 2021 6:51 am
do you need to use the 2 gnd? or have the battery and screen connected?
I didn't have anything connected except the STLINK.

You need the 2nd GND if your controller is locked with readout protection. In that case you need to connect GND with pin 7 of the STM32 to reset it into flashable state.
servacy wrote:
Thu Sep 09, 2021 1:44 pm
mayaku wrote:
Fri Sep 03, 2021 4:23 pm
servacy wrote:
Tue Aug 31, 2021 6:26 pm

I thought that could be the problem, but is it possible, considering the fact that this was not 12V led stripe or something, but small led chain originally powered by 2 AA batteries (it makes 3V right?). Other thing is that I had the spare controller from other Lime and after successful flashing it also gives red "x".

You want to know why your scooter "dies"? In your other post, you mention, in order for you to fit your black box inside the internals (near the motor controller), you had to move the motor down and fit it with one screw. The motor controller needs to be fitted with all three screws in the original location. The mosfets are located nearest to the screws because the external frame acts like a giant heatsink to the controller. Since you moved the original location, the motor controller is over heating and is probably turning itself off to self-protect itself. You should move it back to the original position ASAP (3 screws) as the the different spikes in heat will degrade the life of the motor controller.

Does the red LED on the controller starts flashing when you switch on the scooter?
If it doesn't means you damaged a voltage regulator on the controller. Flashing new firmware is not a problem because it is powered from the ST-Link ;)
To check if a MOSFET is damaged you just have to plug the motor into the controller and turn it. If you feel resistance while turning the motor one or more MOSFETs are broken.

Thank you for your help, but, well, it occurred that after leaving the scooter turned off for couple of days everything went back to normal. I have no idea what was wrong. It is great it works now, but this erratic behaviour makes my scooter unreliable. At least it looks good;)

  • 1
  • 11
  • 12
  • 13
  • 14
  • 15
  • 18

I gave up with flashing and just soldered the tw[…]

Bird 2 spacers !!

Did you ever manage to get that motor mounted to t[…]

New Lime Gen4 (V2) - Okai ES400A

Why do all this? Soldering a new BMS takes 20 minu[…]

anyone know what the pinnout is on the BMS for f[…]