An Electric Scooter Community on a Mission to Stamp out Transportation Mediocrity.

Help, tips, technique, and frequently asked questions.
By dalysea
Posts
#13007
I bought one of these at a flea market for $40. The guy said all it needed was a battery. Ha! It was missing a lot more than that, but a new one appears to cost at least $600 so I figured I could put a little time and money into it.

First problem, I could see it had no controller. I looked online for images matching the scooter and sent photos to the manufacturer in China. We both agreed that since it had an IoT box display, it was set up for sharing and GPS. Initially, I thought that would be a cool thing to have. He sold me a Xiaomi/ESWING sharing controller for $35.

In the meantime, I tried unsuccessfully to cancel my order of a non-sharing controller that came with a display. Both controllers arrived the same day.

2nd problem: The sharing controller had the exact right wires to connect everything together, but when I attached a battery, the display lit up for a second then nothing but 4 flashes of the front light every so often. ESWING guy says yeah you need to scan a QR code to unlock it. Well, I can see where there was a sticker once upon a time, but no more. He referred me to a company called Omni but they never replied to me.

3rd problem: I try with the new display and non sharing controller, but when I hold down the minus button, instead of a steady 6kmh, the motor wheel just jerks a little then nothing.

4th problem: Thinking it might work with the new display and the ESWING controller, I re-wire the pins to match, but it's only a 5 pin, it's missing white (throttle signal). Sure enough, the display turns on but has an Error 10 (Hall Throttle signal error). Throttle signal is between 0.8 volts when no throttle and 3.6 volts at full throttle, so it could tell that not even 0.8 volts were there. But a throttle also requires an input of between 4.3 and 5 volts to work. Well, with the old display, the red and black 5 volt wires were coming from the display board itself and then the resulting throttle signal was sent down the white wire thus making it a 6 pin connector.

5th problem: Where can I get 5 volts to send to the throttle using the new display and ESWING controller? Looking at a wiring diagram later, I suspect I could get it from the red and black wires going to the motor Hall sensor. But I decided to poke around with my voltmeter and see if red and black to the display was 5 volts. After all, the wires are super thin. And in the stupid design of the ESWING controller, red and black are right next to each other and guess what they have the full 48 volts on them aaaand sparks when I accidentally got too close and shorted the wires, melting 2 of the 6 pins.

6th problem: Now that I've destroyed the pins of the ESWING controller, I decide to focus on the new controller and how I can get it to work. It also has a white wire that isn't used for anything so maybe I can send throttle on that just to save myself running more wiring. But it still needs 5 volt input, but this controller has a separate 3 wire connector just for throttle so it has 5 volts. I just need to run it up to the throttle and then get the signal coming back. In the meantime I use an old throttle from an ebike and still get the same jerking behavior. Maybe I need an entirely new motor?

Well, regardless I need to work out the throttle up and down wiring so I ask for the wiring diagram for the non sharing controller. Interestingly, connecting the green wires to each other isn't speed limiter as other wiring diagrams showed. For this controller, connecting green to itself checks the motor direction. So just for kicks I connect it and the scooter shoots backwards. Per instructions, I disconnect and reconnect it temporarily and the scooter shoots forward a couple feet.

Okay, so at this point I'm ready to just use the non sharing controller even though it's only 350 watts and the scooter motor is rated 500 watts. But so far it's the only controller that has actually caused the scooter to move at all. I'm hoping the jerking non-moving behavior was just temporary and that once I run wires for the throttle I can actually get a response.

I thought if that works maybe I coukd try to get the 500 watt controller to work, but honestly at that point I'd almost rather just upgrade to a 1200 watt motor and controller to really make a difference.

Anyone have any similar experience and any advice to offer? Anyone ever successfully use a sharing (QR code given to friends and family) and GPS app (track the scooter) with a personal scooter or was that a pipe dream?

Thanks!

lime scooter question

fair enough. just thought id see what the genera[…]

BIRD ZERO ELECTISAN F350

This is due to incompatible between parts - compli[…]

New Jump scooters

If I bypass bms, scooter usable with stock contr[…]

Bird One + controller swapping

Don't have any experience first hand with the m365[…]