An Electric Scooter Community on a Mission to Stamp out Transportation Mediocrity.

Discuss the Segway Ninebot ES and Ninebot Max Kick Scooter in this Forum. Topics include the Segway-Ninebot app, hardware, street riding, etc.
User avatar
By Aquaman
#21547
Details please, which method and in which order did you flash?

Was it by st-link route?
Or
Ninebot IAP?

If you don't want to say in public please send me a pm to get me going here?

Got the hatch open eventually (without drill), after mutch effort thanks to your pic of the lock.

Now I'm charging up the totally empty battery and want to flash this bad boy :D

Do I start with flashing ESC, Dashboard/BLE or BMS? Have read that you should preferably start with BLE/dashboard on rentals?
User avatar
By Aquaman
#21558
Are you using BLE555?
There's reason not to, according to quoted post below... Having any issues?
Sc00tr wrote:
Mon Mar 16, 2020 3:15 am
BLE555 is not necessary anymore now that the encryption has been broken.

STLinking it to a dash often results in the dash no longer being able to be flashed over IAP or over BLE, and the only way to update it will be by STLinking again.

If you have a windows computer or Xaioflasher on android, flash 1.1.0 FULL instead of 555 as it will allow you to still update.
Btw: Does it work to charge the battery via charging port next to ESC on your scooter? Don't seem to work on mine that isn't flashed in my experience... :cry:
By thisisstan85
#21561
Aquaman wrote:
Wed Jun 17, 2020 2:13 pm
Are you using BLE555?
There's reason not to, according to quoted post below... Having any issues?
Sc00tr wrote:
Mon Mar 16, 2020 3:15 am
BLE555 is not necessary anymore now that the encryption has been broken.

STLinking it to a dash often results in the dash no longer being able to be flashed over IAP or over BLE, and the only way to update it will be by STLinking again.

If you have a windows computer or Xaioflasher on android, flash 1.1.0 FULL instead of 555 as it will allow you to still update.
Btw: Does it work to charge the battery via charging port next to ESC on your scooter? Don't seem to work on mine that isn't flashed in my experience... :cry:
No problem with charging nor ble555 . Maybe its your charger
User avatar
By Aquaman
#21562
thisisstan85 wrote:
Wed Jun 17, 2020 6:26 pm
Aquaman wrote:
Wed Jun 17, 2020 2:13 pm
Are you using BLE555?
There's reason not to, according to quoted post below... Having any issues?
Sc00tr wrote:
Mon Mar 16, 2020 3:15 am
BLE555 is not necessary anymore now that the encryption has been broken.

STLinking it to a dash often results in the dash no longer being able to be flashed over IAP or over BLE, and the only way to update it will be by STLinking again.

If you have a windows computer or Xaioflasher on android, flash 1.1.0 FULL instead of 555 as it will allow you to still update.
Btw: Does it work to charge the battery via charging port next to ESC on your scooter? Don't seem to work on mine that isn't flashed in my experience... :cry:
No problem with charging nor ble555 . Maybe its your charger
Guess you need to update with st-link in the future then :mrgreen: If this post is right. :P

Any particular reason to use BLE555 and not 1.1.0 FULL on this type of scooter?


Well, the charger works when plugged straight in the battery's own port, and also on my other scooter. So that not the problem.

Did you try changing on the port next to SNSC 2.2/2.3's ESC, before flashing?
By thisisstan85
#21564
Aquaman wrote:
Thu Jun 18, 2020 5:02 am
thisisstan85 wrote:
Wed Jun 17, 2020 6:26 pm
Aquaman wrote:
Wed Jun 17, 2020 2:13 pm
Are you using BLE555?
There's reason not to, according to quoted post below... Having any issues?



Btw: Does it work to charge the battery via charging port next to ESC on your scooter? Don't seem to work on mine that isn't flashed in my experience... :cry:
No problem with charging nor ble555 . Maybe its your charger
Guess you need to update with st-link in the future then :mrgreen: If this post is right. :P

Any particular reason to use BLE555 and not 1.1.0 FULL on this type of scooter?

Actually i switched to 1.1.0. No need to ST link again. Just power the dash, hold power button down the whole time and reflash it.

Well, the charger works when plugged straight in the battery's own port, and also on my other scooter. So that not the problem.

Did you try changing on the port next to SNSC 2.2/2.3's ESC, before flashing?
I did, i didnt experience any problems.
User avatar
By Aquaman
#21620
I have flashed BLE/DASH to 1.1.0_FULL

Could connect without IOT-BOX but it didn't recognize anything.
When connecting with IOT-box in parallel, it didn't recognize the model but told me:
DRV 3.3.7
BMS 3.5.6



Where did you connect TTL-serial, did you hook it up in parallel with IOT-BOX?
In what order do you flash, DRV(ESC) and BMS?
I just get connection timed out if I try to flash any of the DRV(ESC) fw, And write length out of range if I try to flash the BMS :(

Any tips, Please?
  • 1
  • 2
  • 3
  • 4
  • 5
  • 8

Right that would be one of the three things […]

Hello JonDon the download links are down, can yo[…]

Flashed dashboard successfully using st-link Fl[…]

I was able to convert MULTIPLE lime scooters aft[…]