An Electric Scooter Community on a Mission to Stamp out Transportation Mediocrity.

Enjoy the juice
By Kuzi
hello, I finally dared to sign up. so far have read many hours here in the forum and have already mastered quite a few projects.

i have a Lime gen3 scooter from an auction and want to unlock it. I removed the controller and the battery and started the experiment.
I have all the files. in the first attempt he had no communication with the controller, the second attempt with pin 7 on GND made the STLink flash blue and it says controller is protected. I tried everything possible for an hour, unfortunately without success. where am I making the mistake? I checked the wiring and pins. everything is correct so far.

is there any other way?

I am very happy about your suggestions and solutions.
By iulisan
Hi.I just cannot manage to read,identify the stm32 with ST-Link and ST link utility.I have the same PCB and i've tried everything (or not).When I connect the controller to the programmer a LED on the controller starts to flash 2 times every 2-3 seconds.I put pin 7 to GND and the same... I just do not understand what did I go wrong.Thanks for any sugestions. :oops:
By Neojunky
In case you still need help.
You have to tie pin7 of the stm to ground, to cause it reset.
You need to make a few tries for timing and hitting pin7.
You have to tie pin7 to ground while plugging in the St-Link and than release it, than you can remove read protection.
By connors
Kuzi wrote:
Wed Nov 10, 2021 5:49 pm
Hey, i have solved the Problem with changing the program. Please use ST Link Utility.
Can you explain how it were successful? Ive been trying all day with no luck. Thanks in advance

Hey people, I'm having problems with my Bird Zero […]

I can't seem to find any info anywhere online […]


For the battery indicator, it worked before. The[…]

How much could you pull max?